Discussion:
Rechner schaltet sich automatisch an
(zu alt für eine Antwort)
Wolfgang Meiners
2008-06-17 15:21:32 UTC
Permalink
Hallo Gruppe,

ich habe hier ein seltsames Problem, das mich zunächst an einen
Virusbefall hat denken lassen: Mein PC schaltet sich seit einigen Tagen
selbst ein! Aber der Reihe nach:

Vor einiger Zeit (ca 1/2 Jahr) habe ich auf meinem Desktop-PC wake on
lan aktiviert. Der PC läuft unter Ubuntu 7.04, um meinen Rechner
aufwecken zu können musste ich auf dem Rechner

ethtool -s eth0 wol g

beim Systemstart ausführen lassen. Das Aufwecken funktionierte dann im
lokalen Netz problemlos. Über einen Router, der unter Openwrt läuft,
konnte ich auch von außen über eine ssh Verbindung den Rechner starten.

Nach dem Openssl/Debian-Debakel habe ich alle Schlüssel auf allen PC's
ausgetauscht.

Das alles lief wie gesagt bis letzte Woche Mittwoch problemlos. Seit
diesem Tag schaltet sich der Rechner selbständig ein, und zwar ziemlich
genau ein halbe Stunde, nachdem ich ihn ausgeschaltet habe.

Zunächst glaubte ich, das hinge mit dem Openwrt-Router zusammen, aber
das Selbsteinschalten geschah auch noch, nachdem ich diesen aus dem Netz
entfernt habe. Nun habe ich das DSL-Modem in Verdacht, weiß aber nicht,
wie das Selbsteinschalten technisch funktionieren könnte.

Auf dem DSL-Modem selbst werden nur zwei Ports weitergeleitet: 443 (ssl
mit Clientkey) und 8022 (ssh). Beide Ports werden auf den Openwrt-Router
geleitet und laufen ins leere, wenn dieser abgeschaltet ist. Trotzdem
schaltet sich mein Rechner reproduzierbar ein. Allerdings nicht seit
Aktivierung von wake on lan, sondern erst seit letzte Woche Mittwoch.

Hat irgendjemand eine Idee, was der Grund für dieses Verhalten sein
könnte und wo ich suchen muss, um das wieder abzuschalten? Ich bin für
jeden Tipp dankbar!

Wolfgang
Bastian Lutz
2008-06-17 16:04:54 UTC
Permalink
Hallo Wolfgang!
Post by Wolfgang Meiners
ich habe hier ein seltsames Problem, das mich zunächst an einen
Virusbefall hat denken lassen: Mein PC schaltet sich seit einigen Tagen
Vor einiger Zeit (ca 1/2 Jahr) habe ich auf meinem Desktop-PC wake on
lan aktiviert. Der PC läuft unter Ubuntu 7.04, um meinen Rechner
aufwecken zu können musste ich auf dem Rechner
ethtool -s eth0 wol g
beim Systemstart ausführen lassen. Das Aufwecken funktionierte dann im
lokalen Netz problemlos. Über einen Router, der unter Openwrt läuft,
konnte ich auch von außen über eine ssh Verbindung den Rechner starten.
Nach dem Openssl/Debian-Debakel habe ich alle Schlüssel auf allen PC's
ausgetauscht.
Das alles lief wie gesagt bis letzte Woche Mittwoch problemlos. Seit
diesem Tag schaltet sich der Rechner selbständig ein, und zwar ziemlich
genau ein halbe Stunde, nachdem ich ihn ausgeschaltet habe.
Zunächst glaubte ich, das hinge mit dem Openwrt-Router zusammen, aber
das Selbsteinschalten geschah auch noch, nachdem ich diesen aus dem Netz
entfernt habe. Nun habe ich das DSL-Modem in Verdacht, weiß aber nicht,
wie das Selbsteinschalten technisch funktionieren könnte.
Trenne man den Rechner vom Netz. Ich hatte mal den tollen Effekt, dass
wenn ein bestimmter anderer Rechner im Netz eingeschaltet war, sich mein
WOL-faehiger Desktop immer wieder eingeschaltet hat.
Post by Wolfgang Meiners
Auf dem DSL-Modem selbst werden nur zwei Ports weitergeleitet: 443 (ssl
mit Clientkey) und 8022 (ssh). Beide Ports werden auf den Openwrt-Router
geleitet und laufen ins leere, wenn dieser abgeschaltet ist. Trotzdem
schaltet sich mein Rechner reproduzierbar ein. Allerdings nicht seit
Aktivierung von wake on lan, sondern erst seit letzte Woche Mittwoch.
Hat irgendjemand eine Idee, was der Grund für dieses Verhalten sein
könnte und wo ich suchen muss, um das wieder abzuschalten? Ich bin für
jeden Tipp dankbar!
Wake-on-RTC im BIOS aktiviert? Z. B. fuer LinVDR gibt's ein NVRAM-Paket,
das diesen Mechanismus programmiert, damit auch ein ausgeschalteter
LinVDR sich einschalten kann, um etwas aufzunehmen.

Ich hatte auch mal zu Analog-Modem-Zeiten das Problem, dass sich beim
ersten Anruf am morgen automatisch der Rechner eingeschaltet hat ->
Wake-on-Ring, gibt's auch fuer ISDN-Karten, USB & Co.

HTH

Bastian Lutz
--
Wenn jemand irgendwas von Anonymitaet faselt, wenn er oder jemand
anderes (meist Newbies) darauf hingewiesen wurde, dass er einen Realname
verwenden sollte, hat er den Hinweis nicht richtig gelesen.
Wolfgang Meiners
2008-06-17 17:33:00 UTC
Permalink
Post by Bastian Lutz
Hallo Wolfgang!
Post by Wolfgang Meiners
ich habe hier ein seltsames Problem, das mich zunächst an einen
Virusbefall hat denken lassen: Mein PC schaltet sich seit einigen
Vor einiger Zeit (ca 1/2 Jahr) habe ich auf meinem Desktop-PC wake on
lan aktiviert. Der PC läuft unter Ubuntu 7.04, um meinen Rechner
aufwecken zu können musste ich auf dem Rechner
ethtool -s eth0 wol g
beim Systemstart ausführen lassen. Das Aufwecken funktionierte dann im
lokalen Netz problemlos. Über einen Router, der unter Openwrt läuft,
konnte ich auch von außen über eine ssh Verbindung den Rechner starten.
Nach dem Openssl/Debian-Debakel habe ich alle Schlüssel auf allen PC's
ausgetauscht.
Das alles lief wie gesagt bis letzte Woche Mittwoch problemlos. Seit
diesem Tag schaltet sich der Rechner selbständig ein, und zwar
ziemlich genau ein halbe Stunde, nachdem ich ihn ausgeschaltet habe.
Zunächst glaubte ich, das hinge mit dem Openwrt-Router zusammen, aber
das Selbsteinschalten geschah auch noch, nachdem ich diesen aus dem
Netz entfernt habe. Nun habe ich das DSL-Modem in Verdacht, weiß aber
nicht, wie das Selbsteinschalten technisch funktionieren könnte.
Trenne man den Rechner vom Netz. Ich hatte mal den tollen Effekt, dass
wenn ein bestimmter anderer Rechner im Netz eingeschaltet war, sich mein
WOL-faehiger Desktop immer wieder eingeschaltet hat.
Post by Wolfgang Meiners
Auf dem DSL-Modem selbst werden nur zwei Ports weitergeleitet: 443
(ssl mit Clientkey) und 8022 (ssh). Beide Ports werden auf den
Openwrt-Router geleitet und laufen ins leere, wenn dieser abgeschaltet
ist. Trotzdem schaltet sich mein Rechner reproduzierbar ein.
Allerdings nicht seit Aktivierung von wake on lan, sondern erst seit
letzte Woche Mittwoch.
Hat irgendjemand eine Idee, was der Grund für dieses Verhalten sein
könnte und wo ich suchen muss, um das wieder abzuschalten? Ich bin für
jeden Tipp dankbar!
Wake-on-RTC im BIOS aktiviert? Z. B. fuer LinVDR gibt's ein NVRAM-Paket,
das diesen Mechanismus programmiert, damit auch ein ausgeschalteter
LinVDR sich einschalten kann, um etwas aufzunehmen.
Ich hatte auch mal zu Analog-Modem-Zeiten das Problem, dass sich beim
ersten Anruf am morgen automatisch der Rechner eingeschaltet hat ->
Wake-on-Ring, gibt's auch fuer ISDN-Karten, USB & Co.
HTH
Bastian Lutz
Ich werd mir die BIOS-Einstellungen auf jeden Fall mal genauer ansehen.

Grüße
Wolfgang
Ansgar Strickerschmidt
2008-06-17 16:24:39 UTC
Permalink
Am 17.06.2008, 17:21 Uhr, schrieb Wolfgang Meiners
Post by Wolfgang Meiners
Das alles lief wie gesagt bis letzte Woche Mittwoch problemlos. Seit
diesem Tag schaltet sich der Rechner selbständig ein, und zwar ziemlich
genau ein halbe Stunde, nachdem ich ihn ausgeschaltet habe.
Schaltest Du immer ziemlich genau eine halbe Stunde nach dem Abschalten
des PCs den Fernseher (den Herd, die Waschmaschine,
$NEUGEKAUFTES_GERAET...) ein, so dass ggf. eine Spannungsschwankung oder
ein HF-Impuls den Einschalter des PC "betätigen" könnte?

Ansgar
--
Mails an die angegebene Adresse errichen mich - oder auch nicht. Nützliche
Adresse gibt's bei Bedarf!
Mail to the given address may or may not reach me - useful address will be
given when required!
Wolfgang Meiners
2008-06-17 17:32:16 UTC
Permalink
Post by Ansgar Strickerschmidt
Am 17.06.2008, 17:21 Uhr, schrieb Wolfgang Meiners
Post by Wolfgang Meiners
Das alles lief wie gesagt bis letzte Woche Mittwoch problemlos. Seit
diesem Tag schaltet sich der Rechner selbständig ein, und zwar
ziemlich genau ein halbe Stunde, nachdem ich ihn ausgeschaltet habe.
Schaltest Du immer ziemlich genau eine halbe Stunde nach dem Abschalten
des PCs den Fernseher (den Herd, die Waschmaschine,
$NEUGEKAUFTES_GERAET...) ein, so dass ggf. eine Spannungsschwankung oder
ein HF-Impuls den Einschalter des PC "betätigen" könnte?
Ansgar
Das ganze muss schon mit wake on lan zusammenhängen, es passiert nämlich
nicht, wenn ich das deaktiviere. Kann das ganze irgendwie mit DHCP oder
mit ARP zusammenhängen? Z.B. dass ein Ping oder ähnliches gestartet
wird, wenn ein Rechner sich längere Zeit nicht mehr gemeldet hat?

Leider habe ich viel zu wenig Ahnung von Netzwerktechnologie, als dass
ich beurteilen könnte, was da abgeht.

Grüße
Wolfgang
Roland Messerschmidt
2008-06-17 18:20:33 UTC
Permalink
Hallo Wolfgang!
Post by Wolfgang Meiners
Kann das ganze irgendwie
mit DHCP oder mit ARP zusammenhängen? Z.B. dass ein Ping oder
ähnliches gestartet wird, wenn ein Rechner sich längere Zeit nicht
mehr gemeldet hat?
Wenn sich dieser Fehler so regelmäßig reproduzieren läßt und du dich
offensichtlich ohnehin mit Linux auskennst, hätte ich einen Vorschlag:

Alten Hub (keinen Switch!) in die Leitung hängen und von einem Laptop
oder zusätzlichen PC aus per Ethereal bzw. Nachfolger Wireshark den
Traffic mitsniffen. Über das verräterische Paket zur richtigen Zeit
könnstest du dann den Verursacher ausfindig machen und dort weiter
forschen.


Roland
Wolfgang Meiners
2008-06-17 20:38:14 UTC
Permalink
Post by Bastian Lutz
Hallo Wolfgang!
Post by Wolfgang Meiners
Kann das ganze irgendwie
mit DHCP oder mit ARP zusammenhängen? Z.B. dass ein Ping oder
ähnliches gestartet wird, wenn ein Rechner sich längere Zeit nicht
mehr gemeldet hat?
Wenn sich dieser Fehler so regelmäßig reproduzieren läßt und du dich
Bei fünf Tests hat sich der Rechner nach 30min +/- 30s eingeschaltet.
Das fand ich schon auffällig.
Post by Bastian Lutz
Alten Hub (keinen Switch!) in die Leitung hängen und von einem Laptop
oder zusätzlichen PC aus per Ethereal bzw. Nachfolger Wireshark den
Traffic mitsniffen. Über das verräterische Paket zur richtigen Zeit
könnstest du dann den Verursacher ausfindig machen und dort weiter
forschen.
Ich werd mal sehen, ob ich einen alten Hub finden kann. Das scheint mir
noch die sinnvollste Lösung zu sein, um weiter zu kommen.
Post by Bastian Lutz
Roland
Grüße
Wolfgang
Ignatios Souvatzis
2008-06-18 07:58:13 UTC
Permalink
Post by Wolfgang Meiners
Post by Bastian Lutz
Hallo Wolfgang!
Post by Wolfgang Meiners
Kann das ganze irgendwie
mit DHCP oder mit ARP zusammenhängen? Z.B. dass ein Ping oder
ähnliches gestartet wird, wenn ein Rechner sich längere Zeit nicht
mehr gemeldet hat?
Wenn sich dieser Fehler so regelmäßig reproduzieren läßt und du dich
Bei fünf Tests hat sich der Rechner nach 30min +/- 30s eingeschaltet.
Das fand ich schon auffällig.
Das klingt aber eher nach WakeOnWecker.

-is

Heiko Nocon
2008-06-17 17:47:51 UTC
Permalink
Post by Wolfgang Meiners
Nun habe ich das DSL-Modem in Verdacht, weiß aber nicht,
wie das Selbsteinschalten technisch funktionieren könnte.
[...]
Post by Wolfgang Meiners
Auf dem DSL-Modem selbst werden nur zwei Ports weitergeleitet: 443 (ssl
mit Clientkey) und 8022 (ssh)
Mir ist nichtmal klar, wie eine Portweiterleitung auf einem DSL-Modem
funktionieren soll. Schließlich ist eine Weiterleitung anhand
irgendwelcher IP-Eigenschaften nur möglich, wenn das Gerät wenigstens
auf IP-Ebene arbeitet.

Das ist aber bei einem DSL-Modem nicht der Fall. Das kann nur Ethernet
auf der lokalen Seite und ATM in Richtung Provider. Sprich: du hast
nicht den Hauch einer Ahnung, wovon du redest. Wenn du auf dem
"DSL-Modem" wirklich irgendwelche IP-Forwards eingerichtet hast, ist's
natürlich kein DSL-Modem, sondern ein Router mit eingebautem DSL-Modem.

Aber unabhängig davon arbeitet WOL natürlich auf Ethernet-Ebene, könnte
also auch ganz ohne irgendeine Weiterleitung auf IP-Ebene funktionieren.
Der Provider braucht dazu nur passende Ethernet-Pakete (in einem
ATM-Rahmen) an dich versenden. Wird der aber normalerweise nicht machen.

Mit abnehmendem Providerpreis werden allerdings Fehlkonfigurationen bei
diesem immer wahrscheinlicher und damit steigt auch die
Wahrscheinlichkeit, daß andere seiner Kunden Wege dazu finden, Pakete an
die lieben Mitkunden erfolgreich zu versenden.
Es gab schon Fälle, wo eine größere Kundengemeinschaft unfreiwillig ein
gemeinsames LAN hatte, in dem sich sogar UDP-Broadcasts ungehindert
verbreiten konnten. Sprich: sie sahen die Windows-Freigaben anderer
Kunden des Providers, die am gleichen AC hingen.

Vermutlich hast du auch einen Billichprovider. Das ist dann KEIN
HARDWAREPROBLEM und deswegen hier OT.
Wolfgang Meiners
2008-06-17 20:24:00 UTC
Permalink
Post by Heiko Nocon
Post by Wolfgang Meiners
Nun habe ich das DSL-Modem in Verdacht, weiß aber nicht,
wie das Selbsteinschalten technisch funktionieren könnte.
[...]
Post by Wolfgang Meiners
Auf dem DSL-Modem selbst werden nur zwei Ports weitergeleitet: 443 (ssl
mit Clientkey) und 8022 (ssh)
Mir ist nichtmal klar, wie eine Portweiterleitung auf einem DSL-Modem
funktionieren soll. Schließlich ist eine Weiterleitung anhand
irgendwelcher IP-Eigenschaften nur möglich, wenn das Gerät wenigstens
auf IP-Ebene arbeitet.
Das wurde sicherlich von mir nicht ganz präzise beschrieben aber -falls
die Nachfrage erlaubt ist- gibt es denn ein DSL-Modem, dass nicht auf
IP-Ebene arbeitet? Ich vermute, dass ich mit meiner Beschreibung deinen
Anforderungen an technologischer Präzision nicht genügen kann.
Wahrscheinlich ist das einer der Gründe dafür, dass ich hier überhaupt
fragen muss.
Post by Heiko Nocon
Das ist aber bei einem DSL-Modem nicht der Fall. Das kann nur Ethernet
auf der lokalen Seite und ATM in Richtung Provider. Sprich: du hast
nicht den Hauch einer Ahnung, wovon du redest.
Da hast du vermutlich recht. Das hindert mich unter anderem daran, meine
Frage so präzise zu stellen, dass die Antwort auf der Hand liegt. Ein
Problem habe ich trotzdem.
Post by Heiko Nocon
Wenn du auf dem
"DSL-Modem" wirklich irgendwelche IP-Forwards eingerichtet hast, ist's
natürlich kein DSL-Modem, sondern ein Router mit eingebautem DSL-Modem.
Um ganz genau zu sein ein Arcor DSL WLAN Modem 100. Die
WAN-Konfiguration ist -natürlich- auf Arcor eingestellt, die
LAN-Konfiguration auf die Netzwerkadresse 192.168.1.1/255.255.255.0,
DHCP ist ausgeschaltet, WLAN ist ausgeschaltet.
Post by Heiko Nocon
Aber unabhängig davon arbeitet WOL natürlich auf Ethernet-Ebene, könnte
also auch ganz ohne irgendeine Weiterleitung auf IP-Ebene funktionieren.
Mir ist nicht ganz klar, wonach ich suchen müsste um das zu bestätigen
oder auszuschließen.
Post by Heiko Nocon
Der Provider braucht dazu nur passende Ethernet-Pakete (in einem
ATM-Rahmen) an dich versenden. Wird der aber normalerweise nicht machen.
Wenn ich das richtig verstehe, braucht er dafür die MAC-Adresse meines
Desktop-PC's. Woher sollte er die haben? Die nächste Frage wäre
natürlich, warum er das tun sollte, wenn er es könnte.
Post by Heiko Nocon
Mit abnehmendem Providerpreis werden allerdings Fehlkonfigurationen bei
diesem immer wahrscheinlicher und damit steigt auch die
Wahrscheinlichkeit, daß andere seiner Kunden Wege dazu finden, Pakete an
die lieben Mitkunden erfolgreich zu versenden.
Es gab schon Fälle, wo eine größere Kundengemeinschaft unfreiwillig ein
gemeinsames LAN hatte, in dem sich sogar UDP-Broadcasts ungehindert
verbreiten konnten. Sprich: sie sahen die Windows-Freigaben anderer
Kunden des Providers, die am gleichen AC hingen.
Davon habe ich gelesen. Ob es für mich zutrifft, weiß ich nicht. Ich
kann es deshalb nicht ausschließen. Was ich von der Anfrage hier in der
Newsgroup erhoffe, ist Information darüber, was passiert sein kann und
wie ich konkrete Dinge genauer analysieren kann.

Grüße
Wolfgang
Heiko Nocon
2008-06-17 23:00:32 UTC
Permalink
Post by Wolfgang Meiners
gibt es denn ein DSL-Modem, dass nicht auf
IP-Ebene arbeitet?
Die Verschwörung geht viel weiter ;o)
Es gibt nämlich sogar _auschließlich_ DSL-Modems, die _nicht_ auf
IP-Ebene arbeiten.
Post by Wolfgang Meiners
Um ganz genau zu sein ein Arcor DSL WLAN Modem 100.
Das ist ein WLAN-Router mit eingebautem DSL-Modem und Vierport-Ethernet
Switch. Eigentlich ein "Zyxel Prestige 660HW-67 DSL-Router", gebrandet
für Arcor.
Post by Wolfgang Meiners
Wenn ich das richtig verstehe, braucht er dafür die MAC-Adresse meines
Desktop-PC's.
Das kommt drauf an, wie die WOL-Funktion der NIC konfiguriert ist.

In der meist sinnvollsten Einstellung reagiert sie nur auf das
WOL-Magic-Paket und zu dessen Konstruktion wird tatsächlich die MAC der
NIC benötigt.

Das ist aber bei (echten) DSL-Modems kein Problem. Da landet die MAC des
Rechners, der die PPPoE-Verbindung aufbaut, natürlich zwingend beim
Provider.
Bei vielen Modems landen sogar praktisch alle Ethernet-Pakete aus dem
heimischen Netzwerksegment (wenn das Modem an einem Switch hängt,
immerhin noch alle Broadcasts) beim Provider.

Darüber hinaus kann das sogar bei etlichen Routern passieren, nämlich
bei denen, die "PPPoE-Forward" beherrschen und diese Funktion aktiv ist.
Lesen Sie weiter auf narkive:
Loading...